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Stay	organized	with	collections	Save	and	categorize	content	based	on	your	preferences.	To	develop	with	Android	12	APIs	and	test	your	app	with	the	Android	12	behavior	changes,	you	need	to	set	up	the	Android	12	SDK.	Follow	the	instructions	on	this	page	to	set	up	the	Android	12	SDK	in	Android	Studio	and	build	and	run	your	app	on	Android	12.	Get
Android	Studio	The	Android	12	SDK	includes	changes	that	are	not	compatible	with	some	older	versions	of	Android	Studio.	For	the	best	development	experience	with	the	Android	12	SDK,	use	Android	Studio	Arctic	Fox	|	2020.3.1	or	higher.	Get	Android	Studio	Install	the	SDK	Within	Android	Studio,	you	can	install	the	Android	12	SDK	as	follows:	Click
Tools	>	SDK	Manager.	In	the	SDK	Platforms	tab,	select	Android	12.	In	the	SDK	Tools	tab,	select	Android	SDK	Build-Tools	31.	Click	OK	to	install	the	SDK.	Update	your	app's	build	configuration	To	access	Android	12	APIs	and	test	your	app's	compatibility	with	Android	12,	open	your	module-level	build.gradle	or	build.gradle.kts	file,	and	update	the
compileSdkVersion	and	targetSdkVersion	with	values	for	Android	12:	android	{	compileSdkVersion	31	defaultConfig	{	targetSdkVersion	31	}	}	android	{	compileSdkVersion(31)	defaultConfig	{	targetSdkVersion(31)	}	}	Note:	If	you	aren't	quite	ready	to	fully	support	Android	12,	you	can	still	perform	app	compatibility	testing	by	using	a	debuggable
app,	an	Android	12	device,	and	the	compatibility	framework,	without	changing	either	your	app's	compileSdkVersion	or	targetSdkVersion.	To	learn	about	which	changes	might	affect	you,	and	to	learn	how	to	test	these	changes	in	your	app,	read	the	following	topics:	To	learn	more	about	new	APIs	and	features	available	in	Android	12,	read	Android	12
features.	Content	and	code	samples	on	this	page	are	subject	to	the	licenses	described	in	the	Content	License.	Java	and	OpenJDK	are	trademarks	or	registered	trademarks	of	Oracle	and/or	its	affiliates.	Last	updated	2021-10-04	UTC.	[{	"type":	"thumb-down",	"id":	"missingTheInformationINeed",	"label":"Missing	the	information	I	need"	},{	"type":
"thumb-down",	"id":	"tooComplicatedTooManySteps",	"label":"Too	complicated	/	too	many	steps"	},{	"type":	"thumb-down",	"id":	"outOfDate",	"label":"Out	of	date"	},{	"type":	"thumb-down",	"id":	"samplesCodeIssue",	"label":"Samples	/	code	issue"	},{	"type":	"thumb-down",	"id":	"otherDown",	"label":"Other"	}]	[{	"type":	"thumb-up",	"id":
"easyToUnderstand",	"label":"Easy	to	understand"	},{	"type":	"thumb-up",	"id":	"solvedMyProblem",	"label":"Solved	my	problem"	},{	"type":	"thumb-up",	"id":	"otherUp",	"label":"Other"	}]	The	Android	Software	Development	Kit	(SDK)	is	a	crucial	part	of	Android	development	for	beginners	to	come	to	grips	with.	It’s	a	selection	of	files	bundled	together
that	you	will	need	to	begin	creating	Android	apps.	It	consists	of	tools	like	the	virtual	device	manager	(emulator)	and	ADB	bridge,	as	well	as	a	library	of	additional	code	for	making	Java	programs	work	with	the	Android	platform.	For	more	on	what	you	get	with	the	Android	SDK,	check	out	the	Android	SDK	tutorial	for	beginners.	Also	read:	Java	tutorial
for	beginners	While	this	might	all	sound	quite	complicated,	there	is	good	news:	you	don’t	need	to	worry	about	the	Android	SDK	much	at	all	anymore.	For	the	most	part	it	will	be	handled	in	the	background	for	you.The	SDK	is	now	included	with	Android	Studio.	Android	development	for	beginners	is	getting	easier	and	easier	and	this	relatively	recent
change	means	you	now	only	need	to	go	through	a	single	installation	to	get	your	development	environment	up	and	running.	There’s	even	an	open	Java	Development	Kit	(JDK)	included,	so	you	no	longer	need	to	separately	install	the	latest	version	separately.Setting	up	Android	development	for	beginners	has	become	a	relatively	streamlined	process.	It
involves	a	few	rather	large	files	—	so	be	prepared	for	that	and	some	lengthy	download	times.	When	you	install	Android	Studio,	you’ll	automatically	get	the	latest	version	of	the	Android	SDK.	The	SDK	is	constantly	being	updated	with	new	features	and	security	updates.	It’s	your	job	to	ensure	you	keep	pace	with	these	changes,	so	you	can	support	the
latest	versions.To	help	you	do	this,	Android	Studio	provides	something	called	an	SDK	manager.	This	is	a	program	specifically	for	downloading	parts	of	your	SDK.	Open	the	manager	by	heading	to	Tools	>	SDK	Manager.	You’ll	be	greeted	with	a	list	of	files	under	the	tabs	SDK	Platforms	and	SDK	Tools.The	SDK	platforms	are	the	Android	platforms	you
can	develop	for.	You	need	at	least	one	to	create	a	working	app.	If	you	choose	the	latest	version,	you’ll	be	able	to	support	all	the	latest	features	of	Android.New	versions	of	Android	should	be	backward	compatible,	so	unless	you	are	a	pro	developer	looking	to	make	use	of	a	cutting	edge	feature,	you’re	probably	fine	to	ignore	this	tab	once	you’ve	gone
through	the	initial	installation.	It	will	make	Android	development	easier	for	beginners.Under	the	SDK	Tools	tab,	you’ll	find	a	list	of	the	other	elements	that	make	up	the	SDK.	You	can	install	these	individually.	Those	that	have	a	blue	box	with	a	dash	through	are	ready	for	updating.	The	most	important	things	here	are	the	Android	SDK	Build-Tools,	the
Android	SDK	Platform-Tools,	and	the	Android	SDK	Tools.	You	may	also	want	the	Android	Emulator	and	system	images	if	you	plan	on	running	and	testing	your	apps	on	your	PC.	In	the	meantime	you	can	mostly	forget	all	about	the	SDK	manager	if	you're	a	beginnerAndroid	Studio	will	let	you	know	if	any	updates	are	mandatory,	so	you	can	mostly	forget
all	about	the	SDK	manager	(likewise,	Android	Studio	itself	will	prompt	you	when	it	is	ready	for	an	update).		Now	you	know	how	to	start	supporting	the	most	recent	versions	of	Android,	once	you	graduate	from	beginner	to	status	that	is.	You	may	be	wondering	whether	you	can	use	the	Android	SDK	on	its	own,	or	whether	you	would	ever	need	to.The	one
use-case	where	this	is	convenient	is	if	you	ever	find	yourself	needing	to	use	a	different	Integrated	Development	Environment	(IDE),	such	as	Unity	(instead	of	Android	Studio).	Unity	is	a	game	engine	and	“game	maker”	that	can	be	used	to	create	Android	games.	You’ll	use	a	completely	different	interface	and	even	a	different	programming	language
(C#),	but	you’ll	still	need	a	copy	of	the	Android	SDK	for	that	program	to	be	compiled	into	an	APK	ready	to	run	on	Android.	The	same	goes	for	Android	development	using	other	tools	like	Xamarin.If	you	want	to	make	it	as	easy	as	possible	to	start	Android	development	as	a	beginner,	I	recommend	you	still	install	Android	Studio	along	with	the	SDK	as
before	(you’ll	still	need	the	JDK	too).	When	you	go	through	this	process,	just	make	a	note	of	the	path	where	the	SDK	is	installed.	Yyou	will	need	this	to	tell	other	IDEs	where	the	SDK	is	located	on	your	computer.	You’ll	find	there’s	the	option	to	enter	the	path	for	the	SDK	somewhere	in	the	settings	(Google	is	your	friend	if	you’re	not	sure	where	that	is),
now	just	copy	and	paste!	Installing	the	Android	SDK	this	way	is	easier	for	beginners,	and	it	also	means	you’ll	have	Android	Studio	on	hand	should	you	ever	want	to	try	traditional	Android	development.	Also	read:	Getting	to	know	Android	Studio	and	the	files	that	make	up	your	appNote	that	depending	on	the	IDE,	you	might	need	to	install	the	Java
Development	Kit	(JDK)	separately	and	provide	a	path	for	this	too.	To	install	the	JDK,	just	head	over	to	this	page	at	Oracle.com	and	download	the	latest	version.	Once	that’s	done,	click	on	the	.exe	file	and	then	follow	the	steps	by	clicking	Next.Some	IDEs	will	give	you	the	option	to	download	Android	Studio	automatically	when	you	go	through	the	set-up
process,	which	is	a	feature	that	is	new	for	Unity.Installing	all	of	these	extra	files	will	take	up	a	lot	of	space	on	your	computer.	If	you’re	really	keen	to	keep	things	to	a	minimum,	you	can	always	download	the	“command	line	tools	only”	option.	You’ll	find	this	by	scrolling	down	the	page	where	you	found	Android	Studio	and	downloading	the	zip	file	for
your	specific	operating	system.	You’ll	find	instructions	on	how	to	use	this	here	and	you	can	grab	the	command-line	tools	from	here.	Theoretically,	this	could	also	be	useful	if	you	ever	want	to	use	a	specific	tool	included	in	the	SDK,	such	as	the	ADB	bridge.That’s	all	there	is	to	downloading	and	installing	the	Android	SDK!	This	is	one	of	the	first	and	most
important	steps	when	it	comes	to	Android	development	for	beginners,	so	well	done!			Android	is	an	Operating	System	for	mobile	devices	developed	by	Google	in	2007,	which	is	built	upon	a	Linux	kernel.	Android	competes	with	Apple's	iOS	(for	iPhone/iPad),	Microsoft's	Windows	Phone,	and	many	other	proprietary	mobile	OSes.	The	latest	Android
supports	Phone/Tablet,	TV,	Wear	(watch	and	glass),	Automobile	and	Internet	of	things	(IoT).	Android	is	based	on	Linux	with	a	set	of	native	core	C/C++	libraries.	Android	applications	are	written	in	Java.	However,	they	run	on	Android's	own	Java	Virtual	Machine,	called	Dalvik	Virtual	Machine	(DVM)	(instead	of	JDK's	JVM)	which	is	optimized	to	operate
on	the	small	and	mobile	devices.	In	May	2017,	Google	announced	support	for	a	new	Kotlin	programming	language.	As	you	are	familiar	with	Java,	you	probably	should	start	in	Java	(many	of	the	examples	out	there	are	written	in	Java),	and	then	move	into	Kotlin.	Kotlin	will	not	be	discussed	in	this	article.	The	mother	site	for	Android	is	.	For	programmers
and	developers,	visit	to	download	the	SDK,	Android	Training,	API	Guides	and	API	documentation.	Installing	Android	software	is	probably	the	most	challenging	part	of	this	project.	It	takes	times	-	from	30	minutes	to	n	hours	to	forever	-	depending	on	your	luck,	your	programming	knowledge,	and	your	PC.	You	probably	need	a	fairly	decent	PC	(with	8GB
RAM)	and	10GB	of	free	disk	space	to	run	the	Android	emulator!!!	Running	on	"actual"	Android	phone/tablet	requires	much	lesser	resources.	Step	0:	Pre-Installation	Check	List	Before	installing	Android	SDK,	you	need	to	install	Java	Development	Kit	(JDK).	Read	"How	to	install	JDK".	Ensure	that	your	JDK	is	at	or	above	1.8.	You	can	check	your	JDK
version	with	command	"javac	-version"	(compiler)	and	"java	-version"(runtime).	Uninstall	older	version(s)	of	"Android	Studio"	and	"Android	SDK",	if	any.	The	installation	and	many	operations	take	a	LONG	time	to	complete.	Do	NOT	stare	at	your	screen	or	at	the	ceiling.	Browse	through	the	"Android	for	Developers"	@	.	We	need	to	install	two	HUGE
packages:	Android	Studio	(IDE)	(about	1.6	GB),	which	is	an	Integrated	Development	Environment	(IDE)	based	on	IntelliJ	(a	popular	Java	IDE);	and	Android	SDK	(Software	Development	Kit)	(about	5	GB)	for	developing	and	running	Android	apps.	Step	1:	Install	"Android	Studio	IDE"	Reference:	"Install	Android	Studio"	@	.	(For	Windows)	Check	that
environment	variable	JAVA_HOME	is	set	to	the	JDK	installation	directory	via	command	"set	JAVA_HOME".	Otherwise,	Follow	the	steps	HERE.	Check	the	system	requirements	for	Android	Studio/SDK	@	e.g.,	For	Windows	10,	8GB	of	RAM,	8GB	of	disk	space,	and	1280x800	minimum	screen	resolution.	Take	note	that	you	should	have	enough	space	on	C
drive.	Insufficient	space	on	C	drive	will	take	you	many	days.	Goto	"Android	Studio"	under	"Android	Developers"	@	⇒	Click	"Download	Android	Studio"	(Android	Studio	Bumblebee	2021.x.x	for	Windows	64-bit	(872MiB))	to	download	the	executable	installer	"android-studio-2021.x.x.xx-windows.exe".	Run	the	downloaded	installer	⇒	You	may	watch	a
short	video	@	.	In	"Choose	Components",	select	"Android	Studio"	and	"Android	Virtual	Device"	(space	required:	2.7GB).	In	"Configuration	Settings	Install	Location",	accept	the	default	"C:\Program	Files\Android\Android	Studio".	In	"Choose	Start	Menu	Folder",	accept	the	default	⇒	Install.	Launch	Android	Studio.	Continue	to	Step	2.	by	default,	the
"Android	Studio	IDE"	will	be	installed	in	"C:\Program	Files\Android\Android	Studio",	and	the	"Android	SDK"	in	"c:\Users\username\AppData\Local\Android\Sdk".	Notes	(SKIP):	You	can	also	use	the	ZIP	version:	Download	the	Windows	64-bit	ZIP	version	(about	1.5GB)	⇒	UNZIP	into	a	folder	of	your	choice	⇒	Run	"bin\studio64.exe"	to	launch	the	Android
Studio	⇒	It	will	enter	the	"setup"	for	the	first	launch	⇒	"Do	not	Import	Settings"	⇒	In	"Welcome",	click	"Next"	⇒	In	"Install	Type",	choose	"Custom"	(so	that	you	can	see	what	is	going	on)	⇒	In	"Select	Default	JDK	Location",	use	default	⇒	In	"Select	UI	Theme",	choose	one	that	you	like	⇒	In	"SDK	Components	Setup",	select	"Android	Virtual	Device
(1.05GB)	⇒	Take	note	of	the	"Android	SDK	Location"	with	default	of	"C:\Users\username\AppData\Local\Android\Sdk"	⇒	In	"Emulator	Settings",	use	default	⇒	In	"Verify	Settings",	check	the	settings	and	choose	"Finish"	⇒	In	"Download	Components",	click	"Details"	and	check	that	nothing	fails	⇒	Wait	⇒	Wait	⇒	Wait.	(For	macOS)	Check	the	system
requirements	@	e.g.,	macOS	10.14	or	higher,	8GB	of	RAM,	8GB	of	disk	space,	and	1280x800	minimum	screen	resolution.	Goto	"Android	Developer"	under	"Android	Developers"	@	⇒	Click	"Download	Options"	⇒	For	Intel	processor,	choose	"Mac	(64-bit)	Android-studio-2021.x.x.xx-mac.dmg	(928MiB)";	for	Apple	M1	ARM	processor,	choose	"Mac	(64-bit,
ARM)	Android-studio-2021.x.x.x-mac_arm.dmg	(925MiB)".	Launch	the	downloaded	".dmg"	installation	file	⇒	You	may	watch	a	short	video	@	.	Drag	and	drop	Android	Studio	into	the	"Applications"	folder.	Continue	to	Step	2.	The	"Android	SDK"	will	be	installed	in	"~/Library/Android/sdk",	where	~	denotes	your	home	directory.	Note:	If	you	see	a	warning
that	says	"the	package	is	damaged	and	should	be	moved	to	the	trash",	goto	"System	Preferences"	⇒	Security	&	Privacy	⇒	under	"Allow	applications	downloaded	from"	⇒	select	"Anywhere".	Then	run	again.	Step	2:	Installing	Android	SDK	This	step	takes	a	long	time	as	you	need	to	download	about	3GB	of	zip	data,	and	expand	to	5	GB	of	disk	data,	even
for	the	minimum	configuration.	Note:	You	can	actually	copy	the	SDK	from	another	computer	with	the	same	OS.	(For	Windows	and	macOS)	Launch	Android	Studio	⇒	It	will	run	the	"setup"	wizard	for	the	first	launch.	Choose	"do	not	import	previous	settings",	and	wait...	In	"Welcome",	choose	"next".	In	"Install	Type",	choose	"Standard"	(default).	In
"Select	UI	Theme",	choose	one	that	you	like	(or	default).	In	"Verify	Settings",	take	note	of	the	SDK	directory	(by	default	@	c:\Users\username\AppData\Local\Android\Sdk	for	Windows,	"~/Library/Android/sdk"	for	macOS):	Setup	Type:	Standard	SDK	Folder:	C:\Users\xxxxxxxx\AppData\Local\Android\Sdk	JDK	Location:	C:\Program	Files\Android\Android
Studio\jre	(Note:	Gradle	may	be	using	JAVA_HOME	when	invoked	from	command	line.	More	info...)	Total	Download	Size:	1.75	GB	SDK	Components	to	Download:	Android	Emulator	329	MB	Android	SDK	Build-Tools	32	54.1	MB	Android	SDK	Build-Tools	32.1-rc1	52.1	MB	Android	SDK	Platform	32	63	MB	Android	SDK	Platform-Tools	11.9	MB	Android
SDK	Tools	149	MB	Intel	x86	Emulator	Accelerator	(HAXM	installer)	500	KB	SDK	Patch	Applier	v4	1.74	MB	In	"License	Agreement",	Accept	ALL	items	⇒	Finish	⇒	Wait	⇒	Wait	⇒	Wait	⇒	Wait	⇒	Wait	⇒	Wait.	(For	Windows)	Use	"File	Explorer"	to	check	the	SDK	installed	directory.	Take	note	that	the	"AppData"	is	a	hidden	directory.	You	need	to	choose
"View"	⇒	Uncheck	"Hidden	Items"	to	see	this	directory.	(For	macOS)	Use	"Finder"	to	check	the	SDK	installed	directory.	You	can	also	use	"Android	Studio"	to	check	the	SDK	packages	installed	by	selecting	"More	Actions"	(or	"Configure"	in	older	versions,	or	"Tools")	⇒	"SDK	Manager"	⇒	"Android	SDK"	(sidebar):	Under	"SDK	Platforms"	tab:	Under	"SDK
Tools"	tab:	Android	SDK	Build	Tools	33-rc1	Android	Emulator	Android	SDK	Platform-Tools	(33.0.0)	Intel	x86	Emulator	Accelerator	(HAXM	installer)	Write	your	First	Android	App	Android	apps	are	written	in	Java	(or	Kotin),	and	use	XML	extensively.	I	shall	assume	that	you	have	basic	knowledge	of	Java	and	XML.	Take	note	that	Android	emulator	is	slow
-	VERY	VERY	VERY	SLOW!!!	Be	Patient!!!	Hello-World	Step	0:	Read	Goto	"Android	Guides"	@	.	Read	"Build	your	first	app".	Step	1:	Create	a	New	Android	Project	Launch	"Android	Studio".	Choose	"New	Project".	Under	"Template"	⇒	select	"Phone	and	Tablet"	tab	⇒	select	"Empty	Activity"	⇒	Next.	In	"Create	a	new	empty	activity"	⇒	Set	"Name"	to
"Hello	Android"	(this	will	be	the	"Title"	in	your	phone's	app	menu)	⇒	The	"Package	name"	and	"Save	Location"	will	be	updated	automatically	⇒	In	"Language",	select	"Java"	⇒	Leave	the	"Minimum	API	Level"	and	the	rest	to	default	⇒	Finish.	Be	patient!	It	could	take	a	few	minutes	to	set	up	your	first	app.	Watch	the	"progress	bar"	at	the	bottom	status
bar	and	Zzzzzzzzz......	If	you	see	"2	processes	running",	you	can	click	on	it	to	see	the	details.	Once	the	progress	bar	indicates	completion,	a	working	hello-world	app	is	created	by	default.	Step	2:	Setup	Emulator	(aka	Android	Virtual	Device	or	AVD)	Reference:	"Create	and	manage	virtual	devices"	@	Note:	The	older	versions	of	Android	Studio	called	the
"emulator"	"Android	Virtual	Device"	or	"AVD".	To	run	your	Android	app	under	an	emulator,	you	need	to	first	create	an	Android	Virtual	Devices	(AVD).	An	AVD	emulates	a	specific	mobile	device	(e.g.,	your	zPone	38	or	Taimi	Green).	In	Android	studio,	select	"Tools"	⇒	"Device	Manager"	(or	"AVD	Manager"	in	earlier	versions).	Under	"Virtual",	click
"Create	Device".	In	"Choose	a	device	definition"	⇒	In	"Category",	choose	"Phone"	⇒	In	"Name",	choose	"Pixel	2"	(or	....)	⇒	Next.	In	"Select	a	System	Image"	⇒	On	the	default	"Recommended",	click	"Download"	⇒	Finish,	and	wait...	In	"Verify	Configuration"	⇒	Finish.	If	you	see	"VT-x	is	disabled	in	BIOS":	Check	your	BIOS	setting	to	ensure	that
"Virtualization	Technology"	is	enabled.	Shutdown	and	re-boot	your	PC	to	enter	the	BIOS	setup.	This	is	machine	dependent.	Google	"Your-PC-brand-and-model	enter	BIOS	setup".	For	example,	for	my	HP	computer	⇒	Boot	⇒	"ESC"	to	enter	BIOS	setup	⇒	Advanced	⇒	System	Options	⇒	Check	"Virtualization	Technology	(VTx)"	⇒	Save	⇒	Exit.	Step	3:	Run
the	Android	App	on	Emulator	Select	the	"Run"	menu	⇒	"Run	app"	⇒	Wait....	(In	older	versions,	you	may	need	to	go	"Available	Virtual	Devices"	and	select	the	AVD	created	earlier).	You	MAY	BE	prompted	to	install	Intel	HAXM	(Hardware	Accelerated	Execution	Manager).	Follow	the	instruction	to	install	HAXM.	Be	patient!	It	may	take	a	few	MINUTES	to
fire	up	the	app	on	the	emulator.	The	status	shows	"Gradle	build	running".	Once	build	completes,	the	emulator	will	be	launched.	You	first	see	a	blank	screen	⇒	wait	⇒	Google	logo	⇒	wait	⇒	G	⇒	wait	⇒	"Android"	⇒	Home	screen	⇒	"Hello,	world!"	message.	If	you	have	problem	running	on	the	emulator,	I	suggest	you	try	to	run	on	an	actual	Android	Phone,
if	you	have	one.	Goto	next	step.	In	the	"Emulator"	pane,	select	"Settings"	⇒	"View	Mode"	⇒	"Float".	Push	the	"HOME"	button	of	the	emulator	⇒	In	the	app	menu,	search	for	"Hello	Android"	app	that	we	have	just	installed.	DO	NOT	CLOSE	THE	EMULATOR,	as	it	really	takes	a	long	time	to	start.	You	could	always	re-run	the	app	(or	run	a	new	app)	on	the
same	emulator.	Try	re-run	the	"Hello	Android"	app	by	selecting	"Run"	menu	⇒	"Run	app".	Common	Errors:	If	everything	fails,	select	"File"	menu	⇒	"Invalidate	Caches	/	Restart..."	⇒	and	wait	...	Cannot	find	"AVD	manager"	in	the	"Tool"	menu:	You	have	missing	packages.	You	should	have	a	window	with	Gradle	alert	with	a	link	which	you	can	click	and
you	will	see	a	window	with	a	prompt	to	download	missing	packages.	When	all	stuff	downloaded	the	"ADV	manager"	should	be	enabled.	If	you	get	an	error	message	"Fail	to	find	target	with	hash	string	'android-26'".	Either	click	the	link	"Install	missing	platform(s)	and	sync	project"	to	install	API-26	(another	GB	download!);	or	Under	"Gradle	Scripts"	⇒
Open	"build.gradle	(Module:	app)"	⇒	Change	"compileSdkVersion"	and	"targetSdkVersion"	from	26	to	27	(we	have	installed	API-27)	and	"com.android.support:appcompat-v7:26.x.x"	to	"27.0.0".	If	you	get	an	error	message	"Re-download	dependencies	and	sync	project	(requires	network)",	click	the	link	to	download.	If	the	message	appears	again:
(Windows)	Goto	"C:\Users\username\.gradle\wrapper\dists"	and	delete	"gradle-x.x-all".	Take	note	the	".gradle"	is	a	hidden	directory	and	you	need	to	enable	viewing	of	hidden	directory.	(Macs)	Goto	"~\.gradle\wrapper\dists"	and	delete	"gradle-x.x-all".	Take	note	the	".gradle"	is	a	hidden	directory	and	you	need	to	enable	viewing	of	hidden	directory.
Restart	Android	Studio.	This	error	is	due	to	poor	network	condition,	resulted	in	corrupted	download.	If	you	encountered	error	"Emulator:	ERROR:	x86	emulation	currently	requires	hardware	acceleration",	Read	"	,	(6),	and	(7).	If	you	encountered	error	"HAX	is	not	working..."	⇒	Open	"SDK	Manager"	⇒	SDK	Tools	⇒	Check	if	"Intel	x86	Emulator
Accelerator	(HAXM	Installer)"	is	installed	⇒	Goto	SDK	Location	(by	default,	"C:\Users\your-username\AppData\Local\Android\Sdk\extras\intel\Hardware_Accelerated_Execution_Manager"	for	Windows	or	"~/Library/Android/sdk/extras/intel/Hardware_Accelerated_Execution_Manager"	for	macOS)	⇒	run	"intelhaxm-android.exe"	to	install	HAXM	⇒	Be
patient!	The	installer	may	take	a	while	to	launch	⇒	Follow	the	screen	instructions	to	complete	the	setup.	Take	note	that:	(a)	In	Windows,	the	"AppData"	directory	is	hidden.	You	need	to	unhide	via	"File	Explorer"	⇒	"View"	menu	⇒	Uncheck	"Hidden	Items.	(b)	In	macOS,	the	"Library"	folder	is	hidden.	You	can	unhide	via	"Finder"	⇒	Go	⇒	Home	⇒	Settings
⇒	Show	View	Option.	If	the	problem	persists,	remove	and	then	re-install.	If	you	encountered	error	"Intel	virtualization	technology	(VT-x)	is	not	turned	on"	⇒	Check	your	BIOS	setting	to	ensure	that	"Intel	virtualization	technology"	is	enabled.	Shutdown	and	re-boot	your	PC	to	enter	the	BIOS	setup.	This	is	machine	dependent.	Google	"Your-PC-brand-
and-model	enter	BIOS	setup".	If	"Intel	virtualization	technology"	is	already	enabled,	this	error	is	probably	caused	by	your	antivirus	software.	Disable	your	antivirus	for	this	session	and	rerun.	See	.	If	you	have	problem	creating	AVD	via	"AVD	Manager"	(On	macOS	having	error	"Studio	quit	unexpectedly"),	open	the	AVD	manager	via	command	line	as
follows:	cd	~/Library/Android/sdk/tools	./android	avd	cd	C:\Users\your-username\AppData\Local\Android\sdk\tools	android	avd	If	the	emulator	flashes	and	disappears,	with	error	message	"error	while	loading	state	for	instance	0x0	of	device	'goldfish_pipe'",	installed	a	newer	version	of	HAXM	@
"C:\Users\username\AppData\Local\Android\Sdk\extras\intel\Hardware_Accelerated_Execution_Manager\intelhaxm-android.exe".	Step	4:	Run	the	App	on	Real	Android	Phones	Reference:	"Run	on	Real	Device"	@	.	To	run	the	Android	app	on	a	REAL	device	(Android	Phone	or	Tablet):	Connect	the	real	device	to	your	computer.	Make	sure	that	you	have
the	"USB	Driver"	for	your	device	installed	on	your	computer.	If	not,	goto	to	Install	OEM	USB	Drivers.	If	you	device	is	not	certified	there,	good	luck!	It	took	me	many	hours	to	find	a	compatible	driver	for	my	cheap	un-brand	Tablet.	Enable	"USB	Debugging"	mode	on	your	real	device:	(On	Android	4.2/5.0	and	newer)	Need	to	enable	"Developer	options"
via	"Settings"	⇒	About	Phone	⇒	Software	Information	(if	there	is	one)	⇒	Tap	"Build	number"	seven	(7)	times	until	"Developer	Mode"	is	displayed.	Return	to	the	"Settings"	menu	to	find	"Developer	options"	⇒	Open	"Developer	options"	⇒	Enable	"USB	debugging".	(On	Android	4.0)	From	"Settings"	⇒	"Developer	options"	⇒	Check	"USB	Debugging".	(On
Android	3.2	and	older)	From	"Settings"	⇒	"Applications"	⇒	"Development"	⇒	Check	"USB	Debugging".	This	allows	Android	SDK	to	transfer	data	between	your	computer	and	your	device.	Also	enable	"Unknown	source"	from	"Applications".	This	allows	applications	from	unknown	sources	to	be	installed	on	the	device.	You	shall	see	the	message	"USB
Debugging	Connected"	(or	"Allow	USB	debugging")	when	you	plugs	the	USB	cable	into	your	computer.	You	can	find	your	device	under	"Tools"	⇒	"Device	Manager"	⇒	"Physical".	(There	is	a	new	option	called	"Pair	with	wifi	in	Andriod	Studio	2021.	To	check!)	From	Android	Studio,	select	"Run"	menu	⇒	"Run	app"	⇒	Your	device	shall	be	listed	under
"Choose	a	running	device"	⇒	Select	the	device	⇒	OK	⇒	"Hello-world"	will	appear	on	your	phone.	In	your	phone's	app	menu,	look	for	the	"Hello	Android"	app	that	we	have	just	installed.	Deleting	a	Project	To	delete	a	project,	select	"File"	⇒	"Close	Project"	⇒	On	the	"Recent	Projects"	⇒	Hover	over	the	project	⇒	Press	"Delete"	key	on	the	project	to	remove
the	project	from	Android	Studio	⇒	You	can	then	delete	the	project	directory	from	the	file	system.	Hello-world	"by	Coding"	There	are	two	ways	to	create	User	Interface	(UI)	on	Android:	Write	Java	codes.	Layout	via	XML	descriptions	and	let	the	system	generates	the	Java	code	for	you.	Let's	begin	with	writing	Java	codes	(because	you	have	learned	Java).
We	shall	continue	from	the	"Hello	Android"	project	created	earlier.	MainActivity.java	Expand	the	"app"	node	(by	clicking	on	the	triangle).	Expand	the	"java"	node.	Expand	the	"com.example.helloandroid"	package	node.	Open	the	"MainActivity.java"	(which	actually	has	already	been	opened).	REPLACE	the	onCreate()	method	as	follows	and	add	the
import	statement.	Do	not	touch	the	rest	of	the	codes,	if	any.	package	......;	import	......;	import	android.widget.TextView;	public	class	MainActivity	extends	......	{	@Override	protected	void	onCreate(Bundle	savedInstanceState)	{	super.onCreate(savedInstanceState);	TextView	textView	=	new	TextView(this);	textView.setText("Hello,	from	my	Java
code!");	setContentView(textView);	}	......	......	}	Run	the	application	("Run"	⇒	"Run	app").	You	shall	see	the	message	"Hello,	from	my	Java	code!"	displayed.	Dissecting	the	"MainActivity.java"	-	Application,	Activity	&	View	An	Android	application	could	have	one	or	more	Activity.	An	Activity,	which	usually	has	a	screen,	is	a	single,	focused	thing	that	the
user	can	interact	with	the	application	(hence	called	activity).	The	MainActivity	extends	the	android.app.Activity	class	(or	android.app.AppCompatActivity	in	the	later	version),	and	overrides	the	onCreate()	method.	The	onCreate()	is	a	call-back	method,	which	is	called	back	by	the	Android	system	when	the	activity	is	launched.	A	View	is	a	UI	component
(or	widget,	or	control).	We	construct	a	TextView	(which	is	a	subclass	View	for	showing	a	text	message),	and	set	its	text.	We	then	set	the	content-view	of	the	MainActivity	screen	to	this	TextView.	Android	Application	Descriptor	File	-	"AndroidManifest.xml"	Each	Android	application	has	a	manifest	file	named	AndroidManifest.xml	under	"app"	⇒
"manifests".	It	describes	the	Android	app.	For	example,	our	"Hello	Android"	application,	with	an	activity	called	MainActivity,	has	the	following	manifest	(generated	automatically	by	the	Android	SDK	when	the	project	was	built):	The	XML	declares	a	TextView	(text	field)	that	holds	a	text	string	"Hello	World!".	The	TextView	component	has	width	and
height	big	enough	to	hold	its	content	("wrap_content").	Step	3:	Defining	String	References	and	Values	in	XML	File	"res\values\string.xml"	Instead	of	hardcoding	the	Hello-World	string	directly	inside	the	TextView	(as	in	the	above	XML	file),	we	shall	use	a	string	reference	(or	variable)	for	better	flexibility.	Expand	res/values	node.	Open	strings.xml,	and
ADD	the	line	in	red:	Hello	Android	XML	Hello	world	from	XML!	This	"string.xml"	defines	2	variables/values:	A	string	variable	"app_name"	contains	the	application's	name,	that	you	entered	when	you	created	the	project.	A	string	variable	"hello"	contains	the	value	of	"Hello	world	from	XML!".	Now,	modify	the	"activity_main.xml"	to	use	the	string
variable	"hello",	in	the	format	"@string/hello",	as	follows:	......	......	Step	4:	Program	the	Activity	in	"MainActivity.java"	Next,	check	the	"MainActitivy.java"	(under	app/java/com.example.helloandroidxml),	as	follows:	package	......;	import	......;	public	class	MainActivity	extends	......	{	@Override	protected	void	onCreate(Bundle	savedInstanceState)	{
super.onCreate(savedInstanceState);	setContentView(R.layout.activity_main);	}	}	The	"MainActivity"	sets	its	content-view	to	"R.layout.activity_main",	which	is	mapped	to	the	XML	layout	file	"res\layout\activity_main.xml"	that	we	have	modified	earlier.	Step	5:	Run	the	App	Run	the	application.	You	shall	see	the	new	string	"Hello,	from	XML!"	displayed.
Uninstall	Android	Studio	IDE	and	Android	SDK	Android	is	huge.	You	probably	want	to	remove	it	after	your	project	sessions.	(For	Windows)	Run	"Control	Panel"	⇒	"Programs	and	Features"	⇒	Uninstall	"Android	Studio";	or	remove	the	ZIP	installed	files.	Delete:	C:\Users\username\AppData\Local\Android\Sdk	(this	directory	contains	the	SDK	and	is	huge,
about	5GB)	C:\Users\username\.android	C:\Users\username\.AndroidStudioX.X	C:\Users\username\.gradle	C:\Users\username\AndroidStudioProjects	(these	are	the	Android	projects	written	by	you)	(For	macOS)	[TODO]	REFERENCES	&	RESOURCES	Latest	version	tested:	Android	12	(S),	Android	Studio	2021	Last	modified:	March,	2022
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