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- In order to create barcodes, we need to convert the cell formatting of our product codes from number to Text.- Select Product codes.- Click on the Home tab, press number formatting dropdown button & select Text cell formatting. In today's business world, barcodes play a crucial role in efficient data management and inventory tracking. By
creating barcodes in Excel 2013, businesses can streamline their operations and save valuable time and resources. In this tutorial, we will provide an overview of the benefits of creating barcodes in Excel 2013 and walk you through the process step by step. Key Takeaways Barcodes are crucial for efficient data management and inventory tracking in
today's business world. Creating barcodes in Excel 2013 can streamline operations and save valuable time and resources for businesses. Understanding the different types of barcodes and their uses is important for effective barcode implementation. Customizing barcodes in Excel 2013 allows for flexibility in barcode size, dimensions, and additional
data for improved tracking and management. Integrating barcode data with other software systems can further enhance inventory management and data tracking efficiency. Understanding barcodes Barcodes have become an essential part of inventory and tracking systems in many industries. Understanding how they work and the different types
available is crucial for efficient and accurate data management. A. What barcodes are and how they work Barcodes are machine-readable representations of data in a visual format. They consist of parallel lines of varying widths and spacing that can be scanned and interpreted by a barcode reader. This allows for quick and accurate data capture
without the need for manual entry. B. Different types of barcodes and their uses There are several types of barcodes commonly used in business and retail settings, including UPC, EAN, Code 39, and Code 128. Each type has its own specific format and is used for different purposes, such as product identification, inventory tracking, and asset
management. C. Importance of using barcodes for inventory and tracking purposes Barcodes play a crucial role in inventory and tracking processes by providing a reliable and efficient way to identify, track, and manage items. They help reduce human error, streamline operations, and improve overall accuracy and efficiency. Setting up Excel 2013 for
barcode creation Creating and using barcodes in Excel 2013 can be a valuable tool for businesses to track inventory, process sales, and manage assets. To get started with barcode generation in Excel 2013, there are a few important steps to follow. A. Understanding the data required for barcode generation 1. Data format: Before creating barcodes in
Excel, it's important to understand the type of data required for barcode generation. This typically includes product numbers, inventory codes, or other unique identifiers that will be encoded in the barcode. 2. Barcode symbology: Different types of barcodes (symbologies) require specific data formats and character sets. Understanding the symbology
requirements will ensure that the barcode is generated correctly and can be scanned accurately. B. Installing barcode font in Excel 2013 1. Downloading the barcode font: In order to display and print barcodes in Excel 2013, a barcode font must be installed on the computer. There are many barcode font options available for download from various
sources. 2. Installing the font: Once the barcode font has been downloaded, it can be installed on the computer by double-clicking the font file and selecting "Install" from the font preview window. C. Adjusting cell formatting for barcode display 1. Selecting the cells: After installing the barcode font, select the cells in Excel where the barcode will be
displayed. 2. Formatting the cells: With the cells selected, change the font to the installed barcode font. This will transform the data in the cells into scannable barcodes. 3. Adjusting cell size: Depending on the length of the data and the type of barcode symbology being used, it may be necessary to adjust the width and height of the cells to
accommodate the barcode display. Creating barcodes in Excel 2013 Barcodes are a crucial element in inventory management and tracking. With Excel 2013, you can easily generate barcodes for your products or assets. In this tutorial, we will guide you through the process of creating barcodes in Excel 2013. Entering data into Excel for barcode
generation Before creating barcodes, you need to have the data that you want to encode. This could be product numbers, serial numbers, or any other unique identifier. Follow these steps to enter the data into Excel: Open Excel: Launch Microsoft Excel 2013 on your computer. Create a new spreadsheet: Start a new spreadsheet or open an existing
one where you want to generate the barcode. Enter the data: Input the data that you want to encode into the cells of the spreadsheet. Each data entry should correspond to a unique barcode. Using the barcode font to display data as a barcode Once the data is entered into Excel, you can use a barcode font to display the data as a barcode. Follow
these steps to do so: Download a barcode font: There are several barcode fonts available for free online. Download a font that is compatible with Excel 2013. Install the font: Install the downloaded barcode font on your computer. Format the cells: Select the cells containing the data and change the font to the barcode font that you installed. The data
will now be displayed as a barcode. Verifying the accuracy of the generated barcode After generating the barcodes, it is essential to verify their accuracy to ensure that they scan correctly. Follow these steps to confirm the accuracy of the generated barcode: Print the barcodes: Print the spreadsheet containing the generated barcodes. Scan the
barcodes: Use a barcode scanner to scan the printed barcodes and verify that they correspond to the correct data. Check for errors: Review the scanned barcodes to ensure there are no errors or discrepancies. Customizing barcodes in Excel 2013 When it comes to creating barcodes in Excel 2013, it’s important to know how to customize them to fit
your specific needs. Whether you need to adjust the size and dimensions of the barcode, add additional data to the label, or format it for printing, Excel offers a range of options for customization. Adjusting barcode size and dimensions Excel 2013 allows you to easily adjust the size and dimensions of the barcode to fit your requirements. To do this,
you can: Change the width and height: You can modify the width and height of the barcode by adjusting the cell size or using the “Format Cells” option. Adjust the barcode type: Excel supports various barcode types, such as Code 39, Code 128, and QR codes, each with its own size and dimension specifications. Adding additional data to the barcode
label Adding extra data to the barcode label can be useful for tracking purposes or including additional information. In Excel 2013, you can: Customize the data format: Excel allows you to format the data within the barcode label to include specific details, such as product codes, serial numbers, or dates. Include supplementary text: You can add text
alongside the barcode to provide context or additional information. Formatting the barcode for printing purposes Formatting the barcode for printing is essential to ensure it is legible and scannable. In Excel 2013, you can: Adjust the resolution: You can modify the resolution of the barcode to ensure it prints clearly and can be easily scanned. Choose
appropriate paper size and orientation: Excel allows you to select the paper size and orientation that best suits your printing requirements. Using barcodes in Excel for inventory management Barcodes are an essential tool for efficient inventory management, and Excel 2013 provides the capability to create and manage barcodes for inventory
tracking. Here are some key points to consider when using barcodes in Excel for inventory management: A. Importing and exporting barcode data in Excel Excel 2013 allows you to import barcode data from other sources, such as barcode scanners or inventory management software. This can streamline the process of updating inventory records and
ensure accuracy. You can also export barcode data from Excel to other systems or devices, providing seamless integration with other inventory management tools. B. Utilizing barcodes for efficient inventory tracking Excel 2013 enables you to create barcode labels for each item in your inventory, making it easy to scan and update inventory records
quickly and accurately. By using barcodes in Excel, you can track the movement of inventory items in and out of your warehouse or storage facilities with minimal effort, helping to maintain accurate inventory levels. C. Integrating barcode data with other software systems Excel 2013 allows you to integrate barcode data with other inventory
management software, providing a seamless flow of data between systems and ensuring accurate and up-to-date inventory records. You can also use Excel to connect barcode data with Enterprise Resource Planning (ERP) systems, ensuring that inventory information is accurately reflected across the entire organization. Conclusion Creating barcodes
in Excel 2013 offers a wide range of benefits, including improved inventory management, faster data entry, and reduced human error. By incorporating barcode creation into your Excel workflow, you can streamline your business operations and enhance overall efficiency. Don't hesitate to utilize the built-in barcode feature in Excel 2013 for more
accurate and efficient data management. Whether you're a business owner or a data analyst, mastering barcode creation in Excel can significantly optimize your workflow and contribute to your overall success. Barcode allows you to show data in a visual format that can easily be read by machines. I am sure you have seen barcodes hundreds of times
on products, including from grocery to clothing. In this tutorial, I will show you how to add a barcode font in Excel so that you can insert barcodes in your worksheet. Something as shown below: Excel allows you to format cells as barcodes, which can be extremely useful, especially in the inventory management. This way, you can create a product
catalog with all barcodes, print product UPC codes, or track items easily. While there is no in-built way in Excel to convert values to barcodes, you can easily do that using the Barcode font. Let’s see how to so this. In order to be able to use barcodes in Excel, you need to download a barcode font and install it first. The most frequently used font is Code
39, and we will use it in examples. You can download the Code 39 font from various free sites for fonts downloading. We did it from Dafont ( . Just click on the Download button next to the Code 39 font. The font will be downloaded in a ZIP folder in your Downloads folder (or wherever you download your files), as a .TTF file (TrueType font). Below are
the steps to install the Barcode font on your system so it’s also available in Excel: Double-click the ZIP folder of the Code 39 font (that you downloaded from the above link) Double-click the .TTF file (when you open a file, you can see the preview of the font) Click on Install. This will install the font on your system Close the dilaog box Now, the font is
installed on your computer and you can use it in applications such as MS Excel. In case you already have a file open, you should save and then reopen it to be able to see it in the barcode font. If you're wondering why this is called Code39, that’s because it generates a barcode that has five bars and four spaces (so a total of 9). And three of these nine
bars would have more width, hence the 3 in 39. Now that the barcode font is installed on your system, let’s see how to use it to create barcodes in Excel. Before I show you how to convert numbers or alphanumeric characters into barcode, you need to know an important thing. The cells that has the numbers (that you want to convert to barcodes) need
to be in the text format. Let me explain why this is important. Excel, in its bid to be as helpful as possible, does some automatic number formatting by default. For example, if you enter 0001 in a cell, it will be converted into 1 (as Excel thinks the leading zeroes are useless). Or if you enter a large number, say 123456789876, Excel will change it to
1.23457E+11. But when you’re generating barcodes, you need the text or the number as is. You don’t want Excel to change it So by converting cells format to text, you ensure that the numbers don’t get truncated or changed by Excel. IMPORTANT: You need to change the cell format before putting the numbers into the cells for which you want the
barcode. So make the cell format Text first, and then enter the numbers. Here is how you can change the cell format to Text Select cells where you plan to have the numbers that you would convert to barcodes. In my example, I will select column A Click on General (Number Format) in the Number part of the Home tab Choose ‘“Text’ Once you have
formatted the cells, you can enter the values that needs to be converted to Barcodes. In case you're copying this data from somewhere, make sure to paste it as values only (so it doesn’t mess up our Text formatting). Now that you have the column formatted as Text, you can enter the values that you converted to barcodes. But I don’t want to convert
the values to barcodes. Instead, I would like to have the value as is and it’s barcode in the adjacent cell. For this, I will have to have the same values in the adjacent column as well. This can be done easily. Below are the steps to copy values from column A to column B. In the cell B2, enter: =A2; Drag the formula down until the last populated cell in
column A (A6). Don’t worry about the formatting on column B. Excel will make sure the formatting is same as that of cells in column A. You can now format the values in column B as barcodes (font Code 39). Below are the steps to do this: Select all cells with values in column B Click on the Font menu in the Home tab Choose Code39 After this, you
get all the values in column B formatted as barcodes. You can also increase the font size in order to make them more visible. Click on the font size menu in the Home tab Choose (for example) 26 As a result, you get a barcode for each text in column A. In our example, the barcode in column B is dynamic, which means that if the value in column A
changes, the barcode would automatically update. In case you don’t want this, you can convert the formula in column B to values. Note that when you install the font on your system, it doesn’t work just in Excel. It would also work on other office applications such as MS Word and MS PowerPoint. Also read: How to Create a QR Code in Excel Code 39
is one of the easiest barcode font to use and includes both numbers and letters. This type displays each character as five bars and four spaces, while three bars are wider than the others. That’s why it got the name 39. Apart from this type, you probably heard of other barcodes, such as Code 128 (similar to 39, usually used for shipping), or UPC/EAN
(used for product barcodes). You can also install and use other barcodes in Excel similar to Code 39. If you’'re the curious type, here is some more information on different types of barcodes. Code 128: It is generally used for shipping and supply chain labels. In comparison with Code 39, the barcodes of Code 128 are denser and are usually used for
container and pallet levels in the supply chain. It can also use the full ASCII character set, which Code39 can only use alphanumeric characters. UPC/EAN: UPC stands for Universal Product Code, EAN for European Article Numbering. This is a widely used barcode that can be found in items in-store and at the point of sale. The character set in UPC
is restricted to 12 characters only. UPC-E: This is a simpler version of UPC, which was developed for smaller packages where the full 12 characters barcode of UPC won’t fit. This is restricted to 6 digits, where the leading and trailing zeroes are omitted. QR: QR stands for Quick Response and is used to open a website or app when you scan it with a
mobile phone camera. You will often find this as a printed code where you can use it to make payments or avail discounts. 120f5: It stands for (Interleaved 2 of 5), where 2 out of every five bars are wide. It is a high-density barcode that supports numeric characters. It is a two-row barcode that’s used on 35 mm film rolls, and to label cartons.

Postnet: It stands for Postal Numeric Encoding Technique and was used by the U.S. Postal Service. It can encode numeric characters only. Intelligent Mail: This one is currently used by the U.S. Postal Service. It encodes up to 65 characters. Apart from the width of the bars and spaces between them, even the height and vertical location of these bars
can be read and converted into information. It uses numeric characters. Now that you know how to easily install the barcode font and use it to create barcodes from numbers and alphanumeric text strings, you can also use Excel to create random barcodes. Suppose you want to generate a random list of 20 barcodes. You can do that using the
RANDBETWEEN formula, where you specify the lower and the upper limit and it will give you random numbers between these two values. For example, if you want to generate random numbers between 1 and 100, you can use the formula RANDBETWEEN(1,100) and enter it into 20 cells to get 20 random values. Below are the steps to generate
random barcodes: In a cell, enter the formula =RANDBETWEEN(1,100) Copy the formula and paste it for 20 cells (or however number of random barcodes you want) Copy the entire range of cells that have these random numbers, and copy it (use Control + C or right-click and then click on Copy) With the cells selected, right-click and then click on
the Paste as Values icon The above steps would generate a list of 20 random numbers and then we have converted these to values (as RANDBETWEEN is a volatile formula and would other keep on updating). Note that this can be done only with numbers. It’s a bit harder to generate random alphanumeric strings. Now that you have random numbers,
you can simply select these and apply the barcode formatting to to. To do this: Select the cells that have the numbers Click the Home tab Select Code39 as the font In case you want the numbers in a separate column and the barcodes in a separate column, you can first copy the numbers in the adjacent column and then apply the barcode font to it.
While using the Excel barcode font technique works fine, there are other ways you can generate barcodes and then use in Excel. There are some decent web based tools as well as applications that you can check out. Some of the prominent bar codes generators include: Barcode.tec Cognex POSGuys Bartender Software So this is how you can use the
Code 39 font to easily generate barcodes in Excel. I hope you found this tutorial useful, Other Excel tutorials you may also like: OverviewSingle cellMultiple cellsBarcode objectVBAFAQ Here is a short description of how to add a barcode to an Excel document and link it with the content of a cell.First, launch Excel and create or open a document.Make
sure that you have configured Excel so that the Developer tab appears. To do so, go to Excel Options by clicking the File tab. This will switch you to the Backstage view. Then, click Options in the tab group on the left.Under Customize Ribbon, enable the Developer option on the main tabs, then close the options window.You can now embed the
ActiveBarcode control element into your document. Select the Developer tab. Click the Insert button from the ActiveX Controls range, and then select More Controls.A dialog box appears on the screen:Select ActiveBarcode and click OK. A barcode will now be created inside your document. It will be a standard EAN-128 barcode. This is the default
type. You can change it to any barcode type supported by ActiveBarcode: QR Code, GS1/EAN-128, Data Matrix, GTIN/EAN-13, Code 39, Code 93, GS1-Data Matrix, Code 128, PDF417, DUN-14, EAN-8, EAN-14, EAN-18, ISBN, ITF-14, NVE, PZN8, SCC-14, SSCC-18, ... You can now modify this barcode. You can change the type, text, colors, etc. To do
so, right-click inside the barcode. A pop-up menu will open: Select ActiveBarcode Object followed by Properties. The ActiveBarcode property dialog will open. You can modify the barcode however you like here.Alternatively, you can use Excel's property dialog. To do so, click the Properties button in the Controls range:Create a link between a cell and
the barcode: Open the Excel property dialog as described above. Activate the barcode object by clicking on it once. The properties of the barcode object will now be displayed in the property dialog. Look for the property named LinkedCell. This property creates a link between a cell and the barcode:Enter the name of the cell for the link into this
property. That's it!If you want to create a barcode that encodes data from several cells, you must first merge these cells into an helping cell. Then connect this combined cell with the barcode object.In the following example the contents of cells B3 and B4 are combined in cell B6. Cell B6 is linked to the barcode object. This site uses cookies to enhance
user experience. By using the site, you agree to this. Read more > First, you'll need to download a barcode font. The most common font — and the one we’ll use in this tutorial — is code 39 (more on that in this section of the article). You can download a version of the font from a number of places, including Dafont, Free Barcode Font, ID Automation,
or Square Gear. Once you download the font, follow Microsoft’s instructions on how to install a font for Office to get it working with your version of Excel.Below are a couple of notes about installing fonts:You may need to quit and restart Excel for the font to appear in your font list.Not all fonts work perfectly for all OSs and versions of Excel. If one
doesn’t operate well, delete it and try another. Code39 has worked best during the research for this article Once you install the font, it’s easy to create barcodes in Excel. Simply follow the steps below.Step One: Create two columns in a blank spreadsheet.Title the columns Text and Barcode. Place the alphanumeric data in the Text column (this is the
basis for the barcodes). The barcodes will appear in the Barcode column. Note: If you want to add a description of each item the barcode applies to, add additional columns to make a table-like layout.Step Two: Format the cells in the Text column.Select the Text column, then right-click on it. Click Format Cells, click Number, click Text. This will
prevent larger numbers from displaying in scientific notation as well as preserving leading zeros. Step Three: Enter the following formula: ="*"&A2&"*" in the first blank row of the Barcode column.In this step, we’re assuming that the cell in the Text column is A2; if not, adjust the formula accordingly. If you there’s no text in the first column, the
second column will display two asterisks. Step Four: Fill the Barcode column down. Step Five: Change the font in the Barcode column.From the font menu, select the downloaded and installed barcode font. It’s a good idea to use the same font for the header row as you do for the rest of the spreadsheet, but that’s up to you. Step Six: Enter
alphanumeric data into the Text column.The Code 39 font can encode 1-9, A-Z (the font considers uppercase and lowercase the same), hyphen (-), dollar sign ($), percent sign (%) period (.), slash (/), plus (+), and a space. The font also encodes the asterisk (*), which is used as an indicator for the beginning and end of the sequence (this is also why the
formula in Step Three adds an asterisk before and after the text entered). The Barcode column will automatically populate with barcodes. Smartsheet is built to handle every use case at any scale. Organize, track, and automate your work effortlessly with Smartsheet's intuitive interface, multiple views, and real-time collaboration features.Try
Smartsheet for Free While creating barcodes in Excel will work well for many, doing so may not be scalable. However, the process is an easy and inexpensive way to do the following: Print product numbers or UPC codes.Produce a product catalog or product list.Track stocked items.All of these capabilities are extremely useful in inventory
management. You can use the RANDBETWEEN Excel function for barcodes that require random numbers. Follow the steps below to automatically create random numbers for barcodes.Note: If you changed the column to text format (see Step Two in the Creating a Barcode in Excel section), change it back to General.Enter the RANDBETWEEN Excel
function. In the first cell of the Text column, enter =RANDBETWEEN(X,Y), where X is the lowest value and Y the highest. For example, =RANDBETWEEN(100,500) will generate random numbers between 100 and 500. Fill down the row to generate random barcode numbers. Each cell will have a random number in the specified range. The 2010,
2013, and 2016 versions of Microsoft Excels can make barcodes. Some older versions may also be able to make barcodes with a supported add-in. This includes those released in 2003 and 2007. In addition to Code 39, there are a number of other barcodes available, including the following: Code 128: This code is generally used for shipping and supply
chain labels. It can encode the same set of characters as Code 39 (though uppercase and lowercase letters can appear differently). There is no length restriction. UPC/EAN: This is the barcode most people are familiar with because it’s used for product barcodes. UPC stands for Universal Product Code; EAN for European Article Numbering. The
barcode is also known as UPC-A and is restricted to 12 characters. 120f5: This is a two row barcode that’s used on rolls of 35mm film, and to label some cartons. It’s also known as industrial 2 of 5 or interleaved 2 of 5, and encodes numeric characters.UPC-E: This is a variation of a UPC barcode where certain characters (e.g., leading zeros) are
omitted, in order to keep the code to six digits. QR: This 2D barcode can be used to open a website or app when scanned with a mobile phone camera. These barcodes are usually used for a printed ticket, to provide a discount, or for mobile payment. The barcode can encode alphanumeric, binary, and kanji. QR stands for Quick Response. Postnet:
Formerly used by the U.S. Postal Service, this barcode encodes numeric characters. Intelligent Mail: Currently used by the U.S. Postal Service, this barcode encodes up to 65 characters. Not only do the width of the bars and spaces carry information, but so do the height and vertical location. Intelligent Mail encodes numeric characters. Also called
the 3 of 9 Barcode, Code 3 of 9, and Barcode39, this option is popular for the following reasons:It’s well-established.It encodes both numbers and letters.It’s readily available for free.Each character display appears as five bars and four spaces; three of the nine bars in the barcode will always be wider. You can also create barcodes in Word,
PowerPoint, Wordpad, TextEdit, and pretty much any app that allows you to change the font. Once you download the font and install it on your computer, enter the text in your program of choice and change the font to the barcode font. Once you've created barcodes, you need to deploy them. You can print or use a barcode in a catalog and then use a
scanner to retrieve the data encoded in the barcode. Scanners can be custom built or off-the-shelf, and you can also use a smartphone that has a designated scanning app. You can create barcodes in Excel on a Mac, just like you would on a PC. Apple’s iOS doesn’t support custom fonts, so you can’t view, edit, or create barcodes on an iPhone. An app
called AllFonts claims it can get past this restriction, but we have not tested it. Android devices accept custom fonts, so you can download a barcode font to your phone and use it in the Excel app to view, edit, and create barcodes using the same steps above. Download and install a barcode font. Create two rows (Text and Barcode) in a blank Excel
spreadsheet. Use the barcode font in the Barcode row and enter the following formula: ="*"&A2&"*" in the first blank cell of that column. Then, fill the formula in the remaining cells in the Barcode row. The numbers/letters you place in the Text row will appear as barcodes in the Barcode row. See step-by-step instructions for Excel 2007 here.
Download and install a barcode font. Create two rows (Text and Barcode) in a blank Excel spreadsheet. Use the barcode font in the Barcode row and enter the following formula: ="*"&A2&"*" in the first blank row of that column. Then, fill the formula in the remaining cells in the Barcode row. The numbers/letters you place in the Text row will appear
as barcodes in the Barcode row. See step-by-step instructions for Excel 2010 here. Download and install a barcode font. Create two rows (Text and Barcode) in a blank Excel spreadsheet. Use the barcode font in the Barcode row and enter the following formula: ="*"&A2&"*" in the first blank row of that column. Then, fill the formula in the remaining
cells in the Barcode row. The numbers/letters you place in the Text row will appear as barcodes in the Barcode row. See step-by-step instructions for Excel 2013 here. Download and install a barcode font. Create two rows (Text and Barcode) in a blank Excel spreadsheet. Use the barcode font in the Barcode row and enter the following formula:
="*'&A2&"*" in the first blank cell of that column. Then, fill the formula in the remaining cells in the Barcode row. The numbers/letters you place in the Text row will appear as barcodes in the Barcode row. See step-by-step instructions for Excel 2016 here. There are a number of websites that will turn alphanumeric text into barcodes. If you don’t
want to use Excel, or you only need a barcode once in a while, the following sites are good options: Barcode.tecBartender SoftwareCognexPOSGuys If you need a lot of barcodes, you can follow these steps to create them individually, but that might be arduous. Another option is to use a barcode generator add-in. You can also use the online bulk
barcode generator offered by POSGuys, and then upload the barcodes to a spreadsheet. You can use barcode scanners with Excel to scan existing barcodes and enter the data into Excel. For example, when a shipping/receiving department gets new parts, they can scan the barcodes on each part and then enter those codes into a Received Parts
spreadsheet. The second way is to use a scanner to scan the barcodes created in Excel via the steps outlined in this article. You can then enter them into a database or other system. An add-in is a software package that allows you to extend Excel’s (as well as other Office applications) functionality. You can use Excel barcode add-ins to create
individual barcodes, lists, or tables, and to set parameters. Below are some examples of add-ins that can help create barcodes:TBar: This is an Excel add-in that can create a single barcode, as well as lists and tables. The add-in allows for direct insertion into cells, and dynamically links to other spreadsheet data. You can also customize the parameters
of the barcodes, including height, width, and check digits.Barcode Resource Encoder: This standalone software package interfaces with Excel and uses macros to create barcodes.ConnectCode: This is a standalone software package to create barcodes. Empower your people to go above and beyond with a flexible platform designed to match the needs
of your team — and adapt as those needs change. The Smartsheet platform makes it easy to plan, capture, manage, and report on work from anywhere, helping your team be more effective and get more done. Report on key metrics and get real-time visibility into work as it happens with roll-up reports, dashboards, and automated workflows built to
keep your team connected and informed. When teams have clarity into the work getting done, there’s no telling how much more they can accomplish in the same amount of time. Try Smartsheet for free, today. Try Smartsheet for Free Get a Free Smartsheet Demo Barcode allows you to show data in a visual format that can easily be read by
machines. I am sure you have seen barcodes hundreds of times on products, including from grocery to clothing. In this tutorial, I will show you how to add a barcode font in Excel so that you can insert barcodes in your worksheet. Something as shown below: Excel allows you to format cells as barcodes, which can be extremely useful, especially in the
inventory management. This way, you can create a product catalog with all barcodes, print product UPC codes, or track items easily. While there is no in-built way in Excel to convert values to barcodes, you can easily do that using the Barcode font. Let’s see how to so this. In order to be able to use barcodes in Excel, you need to download a barcode
font and install it first. The most frequently used font is Code 39, and we will use it in examples. You can download the Code 39 font from various free sites for fonts downloading. We did it from Dafont ( . Just click on the Download button next to the Code 39 font. The font will be downloaded in a ZIP folder in your Downloads folder (or wherever you
download your files), as a .TTF file (TrueType font). Below are the steps to install the Barcode font on your system so it’s also available in Excel: Double-click the ZIP folder of the Code 39 font (that you downloaded from the above link) Double-click the .TTF file (when you open a file, you can see the preview of the font) Click on Install. This will install
the font on your system Close the dilaog box Now, the font is installed on your computer and you can use it in applications such as MS Excel. In case you already have a file open, you should save and then reopen it to be able to see it in the barcode font. If you’'re wondering why this is called Code39, that’s because it generates a barcode that has five
bars and four spaces (so a total of 9). And three of these nine bars would have more width, hence the 3 in 39. Now that the barcode font is installed on your system, let’s see how to use it to create barcodes in Excel. Before I show you how to convert numbers or alphanumeric characters into barcode, you need to know an important thing. The cells that
has the numbers (that you want to convert to barcodes) need to be in the text format. Let me explain why this is important. Excel, in its bid to be as helpful as possible, does some automatic number formatting by default. For example, if you enter 0001 in a cell, it will be converted into 1 (as Excel thinks the leading zeroes are useless). Or if you enter a
large number, say 123456789876, Excel will change it to 1.23457E+11. But when you’re generating barcodes, you need the text or the number as is. You don’t want Excel to change it So by converting cells format to text, you ensure that the numbers don’t get truncated or changed by Excel. IMPORTANT: You need to change the cell format before
putting the numbers into the cells for which you want the barcode. So make the cell format Text first, and then enter the numbers. Here is how you can change the cell format to Text Select cells where you plan to have the numbers that you would convert to barcodes. In my example, I will select column A Click on General (Number Format) in the
Number part of the Home tab Choose “Text’ Once you have formatted the cells, you can enter the values that needs to be converted to Barcodes. In case you’'re copying this data from somewhere, make sure to paste it as values only (so it doesn’t mess up our Text formatting). Now that you have the column formatted as Text, you can enter the values
that you converted to barcodes. But I don’t want to convert the values to barcodes. Instead, I would like to have the value as is and it’s barcode in the adjacent cell. For this, I will have to have the same values in the adjacent column as well. This can be done easily. Below are the steps to copy values from column A to column B. In the cell B2, enter:
=A2; Drag the formula down until the last populated cell in column A (A6). Don’t worry about the formatting on column B. Excel will make sure the formatting is same as that of cells in column A. You can now format the values in column B as barcodes (font Code 39). Below are the steps to do this: Select all cells with values in column B Click on the
Font menu in the Home tab Choose Code39 After this, you get all the values in column B formatted as barcodes. You can also increase the font size in order to make them more visible. Click on the font size menu in the Home tab Choose (for example) 26 As a result, you get a barcode for each text in column A. In our example, the barcode in column B
is dynamic, which means that if the value in column A changes, the barcode would automatically update. In case you don’t want this, you can convert the formula in column B to values. Note that when you install the font on your system, it doesn’t work just in Excel. It would also work on other office applications such as MS Word and MS PowerPoint.
Also read: How to Create a QR Code in Excel Code 39 is one of the easiest barcode font to use and includes both numbers and letters. This type displays each character as five bars and four spaces, while three bars are wider than the others. That’s why it got the name 39. Apart from this type, you probably heard of other barcodes, such as Code 128
(similar to 39, usually used for shipping), or UPC/EAN (used for product barcodes). You can also install and use other barcodes in Excel similar to Code 39. If you're the curious type, here is some more information on different types of barcodes. Code 128: It is generally used for shipping and supply chain labels. In comparison with Code 39, the
barcodes of Code 128 are denser and are usually used for container and pallet levels in the supply chain. It can also use the full ASCII character set, which Code39 can only use alphanumeric characters. UPC/EAN: UPC stands for Universal Product Code, EAN for European Article Numbering. This is a widely used barcode that can be found in items
in-store and at the point of sale. The character set in UPC is restricted to 12 characters only. UPC-E: This is a simpler version of UPC, which was developed for smaller packages where the full 12 characters barcode of UPC won'’t fit. This is restricted to 6 digits, where the leading and trailing zeroes are omitted. QR: QR stands for Quick Response and
is used to open a website or app when you scan it with a mobile phone camera. You will often find this as a printed code where you can use it to make payments or avail discounts. 120f5: It stands for (Interleaved 2 of 5), where 2 out of every five bars are wide. It is a high-density barcode that supports numeric characters. It is a two-row barcode that’s
used on 35 mm film rolls, and to label cartons. Postnet: It stands for Postal Numeric Encoding Technique and was used by the U.S. Postal Service. It can encode numeric characters only. Intelligent Mail: This one is currently used by the U.S. Postal Service. It encodes up to 65 characters. Apart from the width of the bars and spaces between them,
even the height and vertical location of these bars can be read and converted into information. It uses numeric characters. Now that you know how to easily install the barcode font and use it to create barcodes from numbers and alphanumeric text strings, you can also use Excel to create random barcodes. Suppose you want to generate a random list
of 20 barcodes. You can do that using the RANDBETWEEN formula, where you specify the lower and the upper limit and it will give you random numbers between these two values. For example, if you want to generate random numbers between 1 and 100, you can use the formula RANDBETWEEN(1,100) and enter it into 20 cells to get 20 random
values. Below are the steps to generate random barcodes: In a cell, enter the formula =RANDBETWEEN(1,100) Copy the formula and paste it for 20 cells (or however number of random barcodes you want) Copy the entire range of cells that have these random numbers, and copy it (use Control + C or right-click and then click on Copy) With the cells
selected, right-click and then click on the Paste as Values icon The above steps would generate a list of 20 random numbers and then we have converted these to values (as RANDBETWEEN is a volatile formula and would other keep on updating). Note that this can be done only with numbers. It’s a bit harder to generate random alphanumeric strings.
Now that you have random numbers, you can simply select these and apply the barcode formatting to to. To do this: Select the cells that have the numbers Click the Home tab Select Code39 as the font In case you want the numbers in a separate column and the barcodes in a separate column, you can first copy the numbers in the adjacent column and
then apply the barcode font to it. While using the Excel barcode font technique works fine, there are other ways you can generate barcodes and then use in Excel. There are some decent web based tools as well as applications that you can check out. Some of the prominent bar codes generators include: Barcode.tec Cognex POSGuys Bartender
Software So this is how you can use the Code 39 font to easily generate barcodes in Excel. I hope you found this tutorial useful, Other Excel tutorials you may also like: Barcode allows you to show data in a visual format that can easily be read by machines. I am sure you have seen barcodes hundreds of times on products, including from grocery to
clothing. In this tutorial, I will show you how to add a barcode font in Excel so that you can insert barcodes in your worksheet. Something as shown below: Excel allows you to format cells as barcodes, which can be extremely useful, especially in the inventory management. This way, you can create a product catalog with all barcodes, print product
UPC codes, or track items easily. While there is no in-built way in Excel to convert values to barcodes, you can easily do that using the Barcode font. Let’s see how to so this. In order to be able to use barcodes in Excel, you need to download a barcode font and install it first. The most frequently used font is Code 39, and we will use it in examples. You
can download the Code 39 font from various free sites for fonts downloading. We did it from Dafont ( . Just click on the Download button next to the Code 39 font. The font will be downloaded in a ZIP folder in your Downloads folder (or wherever you download your files), as a .TTF file (TrueType font). Below are the steps to install the Barcode font on
your system so it’s also available in Excel: Double-click the ZIP folder of the Code 39 font (that you downloaded from the above link) Double-click the .TTF file (when you open a file, you can see the preview of the font) Click on Install. This will install the font on your system Close the dilaog box Now, the font is installed on your computer and you can
use it in applications such as MS Excel. In case you already have a file open, you should save and then reopen it to be able to see it in the barcode font. If you're wondering why this is called Code39, that’s because it generates a barcode that has five bars and four spaces (so a total of 9). And three of these nine bars would have more width, hence the
3 in 39. Now that the barcode font is installed on your system, let’s see how to use it to create barcodes in Excel. Before I show you how to convert numbers or alphanumeric characters into barcode, you need to know an important thing. The cells that has the numbers (that you want to convert to barcodes) need to be in the text format. Let me explain
why this is important. Excel, in its bid to be as helpful as possible, does some automatic number formatting by default. For example, if you enter 0001 in a cell, it will be converted into 1 (as Excel thinks the leading zeroes are useless). Or if you enter a large number, say 123456789876, Excel will change it to 1.23457E+11. But when you’'re generating
barcodes, you need the text or the number as is. You don’t want Excel to change it So by converting cells format to text, you ensure that the numbers don’t get truncated or changed by Excel. IMPORTANT: You need to change the cell format before putting the numbers into the cells for which you want the barcode. So make the cell format Text first,
and then enter the numbers. Here is how you can change the cell format to Text Select cells where you plan to have the numbers that you would convert to barcodes. In my example, I will select column A Click on General (Number Format) in the Number part of the Home tab Choose ‘“Text’ Once you have formatted the cells, you can enter the values
that needs to be converted to Barcodes. In case you're copying this data from somewhere, make sure to paste it as values only (so it doesn’t mess up our Text formatting). Now that you have the column formatted as Text, you can enter the values that you converted to barcodes. But I don’t want to convert the values to barcodes. Instead, I would like to
have the value as is and it’s barcode in the adjacent cell. For this, I will have to have the same values in the adjacent column as well. This can be done easily. Below are the steps to copy values from column A to column B. In the cell B2, enter: =A2; Drag the formula down until the last populated cell in column A (A6). Don’t worry about the formatting
on column B. Excel will make sure the formatting is same as that of cells in column A. You can now format the values in column B as barcodes (font Code 39). Below are the steps to do this: Select all cells with values in column B Click on the Font menu in the Home tab Choose Code39 After this, you get all the values in column B formatted as
barcodes. You can also increase the font size in order to make them more visible. Click on the font size menu in the Home tab Choose (for example) 26 As a result, you get a barcode for each text in column A. In our example, the barcode in column B is dynamic, which means that if the value in column A changes, the barcode would automatically
update. In case you don’t want this, you can convert the formula in column B to values. Note that when you install the font on your system, it doesn’t work just in Excel. It would also work on other office applications such as MS Word and MS PowerPoint. Also read: How to Create a QR Code in Excel Code 39 is one of the easiest barcode font to use
and includes both numbers and letters. This type displays each character as five bars and four spaces, while three bars are wider than the others. That’s why it got the name 39. Apart from this type, you probably heard of other barcodes, such as Code 128 (similar to 39, usually used for shipping), or UPC/EAN (used for product barcodes). You can also
install and use other barcodes in Excel similar to Code 39. If you're the curious type, here is some more information on different types of barcodes. Code 128: It is generally used for shipping and supply chain labels. In comparison with Code 39, the barcodes of Code 128 are denser and are usually used for container and pallet levels in the supply
chain. It can also use the full ASCII character set, which Code39 can only use alphanumeric characters. UPC/EAN: UPC stands for Universal Product Code, EAN for European Article Numbering. This is a widely used barcode that can be found in items in-store and at the point of sale. The character set in UPC is restricted to 12 characters only. UPC-
E: This is a simpler version of UPC, which was developed for smaller packages where the full 12 characters barcode of UPC won't fit. This is restricted to 6 digits, where the leading and trailing zeroes are omitted. QR: QR stands for Quick Response and is used to open a website or app when you scan it with a mobile phone camera. You will often find
this as a printed code where you can use it to make payments or avail discounts. 120f5: It stands for (Interleaved 2 of 5), where 2 out of every five bars are wide. It is a high-density barcode that supports numeric characters. It is a two-row barcode that’s used on 35 mm film rolls, and to label cartons. Postnet: It stands for Postal Numeric Encoding
Technique and was used by the U.S. Postal Service. It can encode numeric characters only. Intelligent Mail: This one is currently used by the U.S. Postal Service. It encodes up to 65 characters. Apart from the width of the bars and spaces between them, even the height and vertical location of these bars can be read and converted into information. It
uses numeric characters. Now that you know how to easily install the barcode font and use it to create barcodes from numbers and alphanumeric text strings, you can also use Excel to create random barcodes. Suppose you want to generate a random list of 20 barcodes. You can do that using the RANDBETWEEN formula, where you specify the lower
and the upper limit and it will give you random numbers between these two values. For example, if you want to generate random numbers between 1 and 100, you can use the formula RANDBETWEEN(1,100) and enter it into 20 cells to get 20 random values. Below are the steps to generate random barcodes: In a cell, enter the formula
=RANDBETWEEN(1,100) Copy the formula and paste it for 20 cells (or however number of random barcodes you want) Copy the entire range of cells that have these random numbers, and copy it (use Control + C or right-click and then click on Copy) With the cells selected, right-click and then click on the Paste as Values icon The above steps would
generate a list of 20 random numbers and then we have converted these to values (as RANDBETWEEN is a volatile formula and would other keep on updating). Note that this can be done only with numbers. It’s a bit harder to generate random alphanumeric strings. Now that you have random numbers, you can simply select these and apply the
barcode formatting to to. To do this: Select the cells that have the numbers Click the Home tab Select Code39 as the font In case you want the numbers in a separate column and the barcodes in a separate column, you can first copy the numbers in the adjacent column and then apply the barcode font to it. While using the Excel barcode font technique
works fine, there are other ways you can generate barcodes and then use in Excel. There are some decent web based tools as well as applications that you can check out. Some of the prominent bar codes generators include: Barcode.tec Cognex POSGuys Bartender Software So this is how you can use the Code 39 font to easily generate barcodes in
Excel. I hope you found this tutorial useful, Other Excel tutorials you may also like: Barcode allows you to show data in a visual format that can easily be read by machines. I am sure you have seen barcodes hundreds of times on products, including from grocery to clothing. In this tutorial, I will show you how to add a barcode font in Excel so that you
can insert barcodes in your worksheet. Something as shown below: Excel allows you to format cells as barcodes, which can be extremely useful, especially in the inventory management. This way, you can create a product catalog with all barcodes, print product UPC codes, or track items easily. While there is no in-built way in Excel to convert values
to barcodes, you can easily do that using the Barcode font. Let’s see how to so this. In order to be able to use barcodes in Excel, you need to download a barcode font and install it first. The most frequently used font is Code 39, and we will use it in examples. You can download the Code 39 font from various free sites for fonts downloading. We did it
from Dafont (. Just click on the Download button next to the Code 39 font. The font will be downloaded in a ZIP folder in your Downloads folder (or wherever you download your files), as a .TTF file (TrueType font). Below are the steps to install the Barcode font on your system so it’s also available in Excel: Double-click the ZIP folder of the Code 39
font (that you downloaded from the above link) Double-click the .TTF file (when you open a file, you can see the preview of the font) Click on Install. This will install the font on your system Close the dilaog box Now, the font is installed on your computer and you can use it in applications such as MS Excel. In case you already have a file open, you
should save and then reopen it to be able to see it in the barcode font. If you’re wondering why this is called Code39, that’s because it generates a barcode that has five bars and four spaces (so a total of 9). And three of these nine bars would have more width, hence the 3 in 39. Now that the barcode font is installed on your system, let’s see how to
use it to create barcodes in Excel. Before I show you how to convert numbers or alphanumeric characters into barcode, you need to know an important thing. The cells that has the numbers (that you want to convert to barcodes) need to be in the text format. Let me explain why this is important. Excel, in its bid to be as helpful as possible, does some
automatic number formatting by default. For example, if you enter 0001 in a cell, it will be converted into 1 (as Excel thinks the leading zeroes are useless). Or if you enter a large number, say 123456789876, Excel will change it to 1.23457E+11. But when you're generating barcodes, you need the text or the number as is. You don’t want Excel to
change it So by converting cells format to text, you ensure that the numbers don’t get truncated or changed by Excel. IMPORTANT: You need to change the cell format before putting the numbers into the cells for which you want the barcode. So make the cell format Text first, and then enter the numbers. Here is how you can change the cell format to
Text Select cells where you plan to have the numbers that you would convert to barcodes. In my example, I will select column A Click on General (Number Format) in the Number part of the Home tab Choose ‘Text’ Once you have formatted the cells, you can enter the values that needs to be converted to Barcodes. In case you're copying this data
from somewhere, make sure to paste it as values only (so it doesn’t mess up our Text formatting). Now that you have the column formatted as Text, you can enter the values that you converted to barcodes. But I don’t want to convert the values to barcodes. Instead, I would like to have the value as is and it’s barcode in the adjacent cell. For this, I will
have to have the same values in the adjacent column as well. This can be done easily. Below are the steps to copy values from column A to column B. In the cell B2, enter: =A2; Drag the formula down until the last populated cell in column A (A6). Don’t worry about the formatting on column B. Excel will make sure the formatting is same as that of cells
in column A. You can now format the values in column B as barcodes (font Code 39). Below are the steps to do this: Select all cells with values in column B Click on the Font menu in the Home tab Choose Code39 After this, you get all the values in column B formatted as barcodes. You can also increase the font size in order to make them more visible.
Click on the font size menu in the Home tab Choose (for example) 26 As a result, you get a barcode for each text in column A. In our example, the barcode in column B is dynamic, which means that if the value in column A changes, the barcode would automatically update. In case you don’t want this, you can convert the formula in column B to values.
Note that when you install the font on your system, it doesn’t work just in Excel. It would also work on other office applications such as MS Word and MS PowerPoint. Also read: How to Create a QR Code in Excel Code 39 is one of the easiest barcode font to use and includes both numbers and letters. This type displays each character as five bars and
four spaces, while three bars are wider than the others. That’s why it got the name 39. Apart from this type, you probably heard of other barcodes, such as Code 128 (similar to 39, usually used for shipping), or UPC/EAN (used for product barcodes). You can also install and use other barcodes in Excel similar to Code 39. If you're the curious type, here
is some more information on different types of barcodes. Code 128: It is generally used for shipping and supply chain labels. In comparison with Code 39, the barcodes of Code 128 are denser and are usually used for container and pallet levels in the supply chain. It can also use the full ASCII character set, which Code39 can only use alphanumeric
characters. UPC/EAN: UPC stands for Universal Product Code, EAN for European Article Numbering. This is a widely used barcode that can be found in items in-store and at the point of sale. The character set in UPC is restricted to 12 characters only. UPC-E: This is a simpler version of UPC, which was developed for smaller packages where the full
12 characters barcode of UPC won't fit. This is restricted to 6 digits, where the leading and trailing zeroes are omitted. QR: QR stands for Quick Response and is used to open a website or app when you scan it with a mobile phone camera. You will often find this as a printed code where you can use it to make payments or avail discounts. 120f5: It
stands for (Interleaved 2 of 5), where 2 out of every five bars are wide. It is a high-density barcode that supports numeric characters. It is a two-row barcode that’s used on 35 mm film rolls, and to label cartons. Postnet: It stands for Postal Numeric Encoding Technique and was used by the U.S. Postal Service. It can encode numeric characters only.
Intelligent Mail: This one is currently used by the U.S. Postal Service. It encodes up to 65 characters. Apart from the width of the bars and spaces between them, even the height and vertical location of these bars can be read and converted into information. It uses numeric characters. Now that you know how to easily install the barcode font and use it
to create barcodes from numbers and alphanumeric text strings, you can also use Excel to create random barcodes. Suppose you want to generate a random list of 20 barcodes. You can do that using the RANDBETWEEN formula, where you specify the lower and the upper limit and it will give you random numbers between these two values. For
example, if you want to generate random numbers between 1 and 100, you can use the formula RANDBETWEEN(1,100) and enter it into 20 cells to get 20 random values. Below are the steps to generate random barcodes: In a cell, enter the formula =RANDBETWEEN(1,100) Copy the formula and paste it for 20 cells (or however number of random
barcodes you want) Copy the entire range of cells that have these random numbers, and copy it (use Control + C or right-click and then click on Copy) With the cells selected, right-click and then click on the Paste as Values icon The above steps would generate a list of 20 random numbers and then we have converted these to values (as
RANDBETWEEN is a volatile formula and would other keep on updating). Note that this can be done only with numbers. It’s a bit harder to generate random alphanumeric strings. Now that you have random numbers, you can simply select these and apply the barcode formatting to to. To do this: Select the cells that have the numbers Click the Home
tab Select Code39 as the font In case you want the numbers in a separate column and the barcodes in a separate column, you can first copy the numbers in the adjacent column and then apply the barcode font to it. While using the Excel barcode font technique works fine, there are other ways you can generate barcodes and then use in Excel. There
are some decent web based tools as well as applications that you can check out. Some of the prominent bar codes generators include: Barcode.tec Cognex POSGuys Bartender Software So this is how you can use the Code 39 font to easily generate barcodes in Excel. I hope you found this tutorial useful, Other Excel tutorials you may also like: Creating
barcodes in Excel can be useful for inventory management, product labeling, or any scenario where you need to generate scannable codes directly from your spreadsheet data. While Excel doesn’t have a built-in barcode generator, this can be done by using the IMAGE function or by installing a barcode form. In this article, I will show you how to use
both of these methods and also create a barcode generator template in Excel. Click here to download the barcode generator template If you're using Excel with Microsoft 365 or Excel on the web, you would have access to the new image function that makes it very easy to generate barcodes in Excel. Let me show you how it works. Below I have a
dataset where I have some product codes in column A and I want to generate barcodes for them in column F. Here is the formula that will do this: =IMAGE(" &A2) Copy this formula for all the cells in the column. You might have to adjust the row height to make the barcode bigger. The above formula uses an external website called barcodeapi.org
and generates the barcode on this site. Once the barcode is generated on the website, the IMAGE function fetches the image of the barcode into the cell in Excel. Let me explain the URL used in the IMAGE function: - This is the base URL for the BarcodeAPI.org service. It’s the main web address where Excel goes to request a barcode from this
particular service. code128/ - This specifies the type of barcode we want to generate. Unlike the TEC-IT service that uses a parameter, BarcodeAPI.org includes the barcode type directly in the URL path. In this case, we're requesting a Code 128 barcode. If you wanted a Code 39 barcode, you’d change this to “code39/”. &A2 - This is where we attach
the actual data that we want to convert into a barcode. The & symbol joins whatever is in cell A2 to the end of the URL. So if A2 contains “PRD001”, the final URL becomes “ 9. When Excel computes this formula, it combines all these parts to create a complete URL request, sends it to the barcode service wesbite where the bar code is generated.
The IMAGE function then fetches that image into the cell in Excel. The beauty of this approach is that if you change the value in A2, the barcode will automatically update to reflect the new data. I believe this is the easiest way to generate barcodes in Excel, but there are a couple of things to keep in mind: This requires you to have an internet
connection because the image function contacts an external website. If you're generating barcodes in bulk, the barcode generation website may have usage limits The generated barcodes are images, so they’ll scale well when printed If for some reason you are not allowed to open external URLs through your Excel files, you won’t be able to use this
method. In that case, you can see if you're allowed to install barcode fonts on your system, and then you can generate barcodes without using a formula (as shown in the next method) Also read: How to Create QR Codes in Excel (QR Code Generator) In this method, we first need to install a barcode font on our system and then use that to quickly
convert text in a cell into a barcode. Here are the steps to do this: Go to the following website and download Code 39 font on your system. Barcode+39 Open the zip file and double-click on the LibreBarcode39-Regular.ttf file In the dialog box that opens, click on the Install button. This will install the font on your system that can now be used in any
Microsoft application (including Excel). Close all the Excel files that you have open and then restart Excel again. Now let’s use this newly installed barcode font to convert our data into barcode. Below I have a dataset where I want to convert the text in column A into bar codes and get them in column F. Here are the steps to do this. In column F, enter
the following formula ="*"&A2&"*" Select the cell and then go to Home tab and change the font to Libre Barcode 39 Increase the font size and adjust the row height to make the barcode bigger That’s it! You're done. You can now check with any barcode reader machine, and your barcode should be working fine. A few important things you need to
know when using this method: Barcode 39 font only works with uppercase letters. If you have lowercase letters and you use the Barcode39 font, you would still see the barcode but it won’t work with a scanner. If you share this file with someone else who does not have the same barcode font installed, they would just see the regular text. This is a
quirk when using barcode fonts that you need to apply specific encoding to the text for it to be readable by the barcode scanners. With font barcode 39, you need to have an asterisk before and after the text for it to be recognized as a proper barcode by the scanners. If you do not add this, while you may get the barcode, it won’t be correct and the
scanner might not even read it. If you want to use barcode font 128, it gets a lot more complicated as it needs a different kind of encoding. While with code 39, we were able to add asterisk before and after the text and make the barcode work, with code 128 you need to have a calculated checksum digit value after the code which is difficult to
calculate and may not always work. I’ve seen some formulas online that try to calculate this value and append it to the text. I wasn’t able to reliably replicate it in all the cases. So I recommend you stick with using the IMAGE function when generating Code 128 barcode as the encoding is done by the barcode generating website and your IMAGE
function then fetches the image into the cell. Use the IMAGE Function Method when: You have Excel 365 or using Excel on the Web Internet connection is available You have the permission to access external URLs from your Excel file. Use the Font Method when: You need to work offline You’'re using older Excel versions You want more control over
barcode appearance You're comfortable with barcode formatting requirements (such as adding an asterisk before and after the text) In this article, I've covered how to quickly generate barcodes in Excel using the image function and using a specific barcode font. I hope you found this article helpful.If you have any questions or suggestions for me,
please let me know in the comment section. Other Excel articles you may also like: This is a step-by-step guide on how to create a barcode in Excel. Generating barcodes takes only a few steps, but you will need to download and install a free barcode font. The alternative would be to use Excel barcode add-ins.You can download the Excel spreadsheet
I've used when making this tutorial.Excel barcode spreadsheet DownloadIf you want to create a barcode in Excel that any barcode scanner can recognize, follow the steps described below.Step 1: Download and install the barcode font Libre Barcode 39.If you prefer a two-row barcode, you can use Libre Barcode 39 Text (this also includes the text
under the barcode). If you haven’t installed fonts before, read this tutorial from Microsoft.Note: Other barcode fonts are available online, but I prefer to use Google Fonts. Feel free to do your research and choose the one that best fits your project.Step 2: Launch Excel and create a blank spreadsheet.Step 3: Create two columns named Code and
Barcode.The Code column will store the alphanumeric data, which is used to generate the barcode. The Barcode column will contain the actual barcodes.Step 4: Format the cells in the Code column as Text.To convert cell format to Text, select the Code column, right-click on it, and select Format Cells.From the Format Cells dialog box, select the Text
format, and click OK.Note: This step is needed to prevent Excel from removing leading zeros from your codes.Step 5: Enter the formula ="*"&B3&"*" in the first empty cell from the Barcode column.Copy the formula downwards to as many cells as needed. The asterisk (*) symbol indicates the beginning and the end of the sequence.Note: If your data
is stored in other columns, adjust the formula accordingly.Step 6: Select the cells from your Barcode column (except for the header row) and change the font to Libre Barcode 39.Navigate to the Home tab with the cells selected and choose Libre Barcode 39 from the Font menu. Also, increase the font size to match your needs. I have used a font size of
26.Step 7: Enter alphanumeric data into the Code column to generate the barcodes.You can use the RANDBETWEEN function to generate random numbers. The RANDBETWEEN function uses two arguments (bottom, top) to generate a random number. Using the bottom and top arguments, you can control the range of potential random
numbers.Using the same process described in the previous section, you can also create a barcode that is randomly generated.I have created a random barcode generator using the following formula:="*"&RANDBETWEEN(B3,C3)&"*"where:cell B3 is the bottom limit for the barcode generatorcell C3 is the top limit for the barcode generatorl have
included the Excel spreadsheet I've used to create random barcodes. Download it and use it as you please. Just make sure to install the barcode font or change it to the one you have installed.Excel random barcode generatorDownloadIf you don’t want to create barcodes manually, you can use an Excel add-in. I have included a list with some of the
most popular add-ins to create barcodes:TBarCode OfficeConnectCodeIDAutomationActiveBarcodeOnBarcodeAfter reading this tutorial, I hope that you are better equipped to create barcodes in Excel. If you struggle to replicate the process shown in this article, drop me a comment below, and I'll help you out as soon as possible. Barcode allows you
to show data in a visual format that can easily be read by machines. I am sure you have seen barcodes hundreds of times on products, including from grocery to clothing. In this tutorial, I will show you how to add a barcode font in Excel so that you can insert barcodes in your worksheet. Something as shown below: Excel allows you to format cells as
barcodes, which can be extremely useful, especially in the inventory management. This way, you can create a product catalog with all barcodes, print product UPC codes, or track items easily. While there is no in-built way in Excel to convert values to barcodes, you can easily do that using the Barcode font. Let’s see how to so this. In order to be able



to use barcodes in Excel, you need to download a barcode font and install it first. The most frequently used font is Code 39, and we will use it in examples. You can download the Code 39 font from various free sites for fonts downloading. We did it from Dafont ( . Just click on the Download button next to the Code 39 font. The font will be downloaded
in a ZIP folder in your Downloads folder (or wherever you download your files), as a .TTF file (TrueType font). Below are the steps to install the Barcode font on your system so it’s also available in Excel: Double-click the ZIP folder of the Code 39 font (that you downloaded from the above link) Double-click the .TTF file (when you open a file, you can
see the preview of the font) Click on Install. This will install the font on your system Close the dilaog box Now, the font is installed on your computer and you can use it in applications such as MS Excel. In case you already have a file open, you should save and then reopen it to be able to see it in the barcode font. If you're wondering why this is called
Code39, that’s because it generates a barcode that has five bars and four spaces (so a total of 9). And three of these nine bars would have more width, hence the 3 in 39. Now that the barcode font is installed on your system, let’s see how to use it to create barcodes in Excel. Before I show you how to convert numbers or alphanumeric characters into
barcode, you need to know an important thing. The cells that has the numbers (that you want to convert to barcodes) need to be in the text format. Let me explain why this is important. Excel, in its bid to be as helpful as possible, does some automatic number formatting by default. For example, if you enter 0001 in a cell, it will be converted into 1 (as
Excel thinks the leading zeroes are useless). Or if you enter a large number, say 123456789876, Excel will change it to 1.23457E+11. But when you’re generating barcodes, you need the text or the number as is. You don’t want Excel to change it So by converting cells format to text, you ensure that the numbers don’t get truncated or changed by
Excel. IMPORTANT: You need to change the cell format before putting the numbers into the cells for which you want the barcode. So make the cell format Text first, and then enter the numbers. Here is how you can change the cell format to Text Select cells where you plan to have the numbers that you would convert to barcodes. In my example, I
will select column A Click on General (Number Format) in the Number part of the Home tab Choose ‘Text’ Once you have formatted the cells, you can enter the values that needs to be converted to Barcodes. In case you’re copying this data from somewhere, make sure to paste it as values only (so it doesn’t mess up our Text formatting). Now that you
have the column formatted as Text, you can enter the values that you converted to barcodes. But I don’t want to convert the values to barcodes. Instead, I would like to have the value as is and it’s barcode in the adjacent cell. For this, I will have to have the same values in the adjacent column as well. This can be done easily. Below are the steps to
copy values from column A to column B. In the cell B2, enter: =A2; Drag the formula down until the last populated cell in column A (A6). Don’t worry about the formatting on column B. Excel will make sure the formatting is same as that of cells in column A. You can now format the values in column B as barcodes (font Code 39). Below are the steps to
do this: Select all cells with values in column B Click on the Font menu in the Home tab Choose Code39 After this, you get all the values in column B formatted as barcodes. You can also increase the font size in order to make them more visible. Click on the font size menu in the Home tab Choose (for example) 26 As a result, you get a barcode for each
text in column A. In our example, the barcode in column B is dynamic, which means that if the value in column A changes, the barcode would automatically update. In case you don’t want this, you can convert the formula in column B to values. Note that when you install the font on your system, it doesn’t work just in Excel. It would also work on other
office applications such as MS Word and MS PowerPoint. Also read: How to Create a QR Code in Excel Code 39 is one of the easiest barcode font to use and includes both numbers and letters. This type displays each character as five bars and four spaces, while three bars are wider than the others. That’s why it got the name 39. Apart from this type,
you probably heard of other barcodes, such as Code 128 (similar to 39, usually used for shipping), or UPC/EAN (used for product barcodes). You can also install and use other barcodes in Excel similar to Code 39. If you're the curious type, here is some more information on different types of barcodes. Code 128: It is generally used for shipping and
supply chain labels. In comparison with Code 39, the barcodes of Code 128 are denser and are usually used for container and pallet levels in the supply chain. It can also use the full ASCII character set, which Code39 can only use alphanumeric characters. UPC/EAN: UPC stands for Universal Product Code, EAN for European Article Numbering. This
is a widely used barcode that can be found in items in-store and at the point of sale. The character set in UPC is restricted to 12 characters only. UPC-E: This is a simpler version of UPC, which was developed for smaller packages where the full 12 characters barcode of UPC won't fit. This is restricted to 6 digits, where the leading and trailing zeroes
are omitted. QR: QR stands for Quick Response and is used to open a website or app when you scan it with a mobile phone camera. You will often find this as a printed code where you can use it to make payments or avail discounts. I120f5: It stands for (Interleaved 2 of 5), where 2 out of every five bars are wide. It is a high-density barcode that
supports numeric characters. It is a two-row barcode that’s used on 35 mm film rolls, and to label cartons. Postnet: It stands for Postal Numeric Encoding Technique and was used by the U.S. Postal Service. It can encode numeric characters only. Intelligent Mail: This one is currently used by the U.S. Postal Service. It encodes up to 65 characters.
Apart from the width of the bars and spaces between them, even the height and vertical location of these bars can be read and converted into information. It uses numeric characters. Now that you know how to easily install the barcode font and use it to create barcodes from numbers and alphanumeric text strings, you can also use Excel to create
random barcodes. Suppose you want to generate a random list of 20 barcodes. You can do that using the RANDBETWEEN formula, where you specify the lower and the upper limit and it will give you random numbers between these two values. For example, if you want to generate random numbers between 1 and 100, you can use the formula
RANDBETWEEN(1,100) and enter it into 20 cells to get 20 random values. Below are the steps to generate random barcodes: In a cell, enter the formula =RANDBETWEEN(1,100) Copy the formula and paste it for 20 cells (or however number of random barcodes you want) Copy the entire range of cells that have these random numbers, and copy it
(use Control + C or right-click and then click on Copy) With the cells selected, right-click and then click on the Paste as Values icon The above steps would generate a list of 20 random numbers and then we have converted these to values (as RANDBETWEEN is a volatile formula and would other keep on updating). Note that this can be done only with
numbers. It’s a bit harder to generate random alphanumeric strings. Now that you have random numbers, you can simply select these and apply the barcode formatting to to. To do this: Select the cells that have the numbers Click the Home tab Select Code39 as the font In case you want the numbers in a separate column and the barcodes in a
separate column, you can first copy the numbers in the adjacent column and then apply the barcode font to it. While using the Excel barcode font technique works fine, there are other ways you can generate barcodes and then use in Excel. There are some decent web based tools as well as applications that you can check out. Some of the prominent
bar codes generators include: Barcode.tec Cognex POSGuys Bartender Software So this is how you can use the Code 39 font to easily generate barcodes in Excel. I hope you found this tutorial useful, Other Excel tutorials you may also like: Watch Video - Create Barcode in Excel Steps: Download the IDAHC39M font and install it. Restart MS Excel.
Select cell B5 and enter any number for your barcode. Go to the Home tab and the Number option. Set the format to Text. Enter the following formula in cell C5: You should get the results as shown below. Navigate to the Home tab and click on the Font Find the font IDAHC39M and select it. You should get your desired barcode. Drag the Fill handle
to copy the format to other cells. Read More: How to Convert Numbers to Barcode in Excel Method 2 - Create Barcode in Excel for Random Number Steps: Select cell B5 and enter the following formula: You can set any numbers for the range. Press Enter to get a random number within the set range. Enter the following formula in cell C5: Set the
font to IDAHC39M and hit Enter. You will get a random barcode. Click and drag the Fill Handle for both cells. Read More: How to Generate 2D Barcode in Excel Method 3 - Insert Barcode Using Excel TBarCode Add-In Steps: Download the latest version of the TBarCode Add-In. Install the Add-in. Restart your computer and open Excel, and you should
see the Add-ins tab activated. Go to the Add-ins tab and click the TBarCode Panel. Set a barcode type and enter your number in the Data field. Set the Size to ‘Fixed Module Width’. Hit the ‘Insert Barcode’ button. You will get the barcode in your set format. Read More: How to Create Barcode Without Font in Excel Download Practice Workbook This
barcode API will generate a barcode image based on your data input and you can use it with the above URL. Append your data on the end in place of the part and the URL will generate an image for that data.Add the data you want to transform to a barcode in an Excel table.= " & [@[Product Code]]Add the above formula to table where [@[Product
Code]] refers to the column containing the data to turn to a barcode. This is the URL that will generate the image in your Power BI data types.Now you will be able to import this data into the Power BI desktop app. Go to the Home tab and click on the Excel Workbook command.This will open a file picker where you can select the Excel file with your
data.When you select your Excel file, this will open up the Navigator menu which lists all the sheets and tables in the the file. Select the table that contains your data and press the Load button.Now go to the Model View in the Power BI desktop app. Select the table and toggle on the Is featured table option in the Properties window pan.When you
toggle on the Is featured table option it will open the Set up this featured table menu and you’ll need to select the Row label and Key column for your table.The Row label is the value that will display in cell for your data type.The Key column should be a unique value across all the rows in the table.The Row label and Key column can be the same
column.Now that your table is set up as a featured table, you will need to set the URL column to an image type.Go to the Data View and select the column in your table with the API URL and choose Image URL in the Data category options.Your Power BI dataset is now ready to publish to the Power BI service. Go to the Home tab and click on the
Publish command.This will open the Publish to Power BI menu where you will be able to select the workspace to which the dataset will be published. Note: Publishing to My workspace won’t allow you to access the dataset as a data type in Excel. Choose any other workspace you have access to.Make sure you are signed into Excel with an account in
the same tenant as the workspace where you published the Power BI data set. You can close and reopen Excel if you don’t immediately see the new data type in the Data tab.Now you will be able to convert any text from the Row label column to a data type.Select the range of cells to convert to a data type.Go to the Data tab.Click on the button in the
lower right of the Data Type tray in the Data Types section to expand and see all the available data types.Click on the newly created data type in the From your organization section.Thi converts the text to your custom data type. You will see a small briefcase icon to the left of the text to indicate it’s now a data type.When you select the cells with your
data types, you will see a small button on the top right of your selection. This is the extraction button andn it allows you to get any column of data from your data type.Click on the Extract button and select the URL column. This will extract the barcode image into the adjacent column.= B2.URLThis places the above dot formula referencing the data
type cell and the URL displays as an image.This is really cool because the value in column B contains both the product code text and the image of the barcode for that product code.Using the Power BI data types to create a barcode image can be a complex process.Thanksfully, there is a way to get the same image into Excel without the need to use
Power BI and set up a data type.You can use the IMAGE function to create same barcode.The IMAGE fucntion takes a URL for an image and returns image in the cell.= IMAGE ( " & B3 )The above formula will append on the data in cell B3 to the end of the barcode API. Then in the IMAGE function will return an image of a barcode for that data in cell
B3.Barcodes have been a long standing way to create scannable codes associated with physical items. You can easily make them in Excel.Using a custom barcode code font is the easiest method to generate barcodes, however they won’t show as barcodes when you share the file to anyone without the font installed.Power BI data types can be used
with an API to create bar code images inside a cell. But you will require a Power BI pro license to get it done.The best option in most cases is likely to generate your barcodes using the IMAGE function.Did you know you could make barcodes in Excel? Let me know in the comments section below!
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